Frotcom is not responding
Incident Report for Frotcom
Resolved
This incident has been resolved.
Posted Dec 26, 2021 - 08:27 WET
Investigating
We are currently investigating the issue.
Posted Dec 26, 2021 - 08:14 WET
This incident affected: Frotcom Application (Frotcom HTML5, Fleet Manager App).