Website down
Incident Report for Frotcom
Resolved
Website is back on. We will give more details by email later.
Posted Dec 30, 2023 - 13:21 WET
Monitoring
Website is back on. We will give more details by email later.
Posted Dec 30, 2023 - 12:53 WET
Investigating
Website is down. Please access Frotcom via web.frotcom.com. We will update you as soon as possible.
Posted Dec 30, 2023 - 12:35 WET
This incident affected: Frotcom Website.